Skip to main content
Eli Tribe TEAM
Community Success Manager at Tribe
Asked a question last year

What are the bugs on Tribe that you would like to report?

This is a feedback question! You can provide multiple answers.

Where am I?

In Tribe you can ask and answer questions and share your experience with others!

Daniel Paul
Full-Stack Developer & Community Builder

✅ This bug has been fixed

Some UI dropdown issues on mobile. The arrow alignment is off and the dropdown goes in the direction where there is no space. It should go the other way where there is space. Please find screenshots of this issue on mobile. 

in a single post
in a single post

Please move inline CSS to the stylesheet. It's difficult to override inline CSS and isn't ideal.

Daniel Paul
Full-Stack Developer & Community Builder

Found a weird menu disappearing issue on mobile. This is what my menu looks like on desktop which I would expect to be displayed on mobile also. 

What are the bugs on Tribe that you would like to report?

But, the groups section is missing on mobile although I see the divider on the menu for it. It must be some display issue?

What are the bugs on Tribe that you would like to report?

BUT, sometimes and this happens quite some a lot when you are just browsing the site and coming back to the homepage for the menu, that the topics section also disappears.

What are the bugs on Tribe that you would like to report?


✅This bug has been fixed

What are the bugs on Tribe that you would like to report?

This column need to improve in mobile view..

On the quick post when you post a URL it automatically pulls in the preview text + image but once you save it and then edit it again, the preview image stops showing.

✅ This bug has been fixed

Unapproved posts visible to other users: I've noticed this happening a couple of times; it seems I can sometimes see not-yet-approved posts by other users. Look at this screenshot and note that I am not the person who has the non-approved post.

What are the bugs on Tribe that you would like to report?

Comment text box is visible and active for non-logged in visitors. They are redirected when clicking post button, but the box should be hidden/removed unless user is logged in.

✅ This bug has been fixed

Hey Team, this is just quite a day, I joined Tribe,  the community offer great facilities to build a perfect community for us, however, I recently faced an issue with it, I thought it should be noticed by you to0, whenever I share any of the questions or something from the community (In Mobile Version) I saw half of the portion is not displayed. 

Here is the screenshot of that. And please do the necessary changes to set the thing up.

Thank you.

What are the bugs on Tribe that you would like to report?
Need to have a custom icon colour and style of icon.
Need to have a custom icon colour and style of icon.

Icon in header section need to have a custom colour and custom icon so admin can change it with own icon style

On a question when you attach an image and it's still uploading, and hit the post button, the question will be send without the selected image.

In Progress. 

When one wants to have a paragraph break in a comment (I.e insert a blank line), then the blank line is remove when you post the comment. 


When I typed the comment, there was a blank link in-between the two lines, that were 'removed' when posting the comment. 

Testing for paragraph break.

[blank line]

Testing for paragraph break.

What are the bugs on Tribe that you would like to report?
Daniel Paul
Full-Stack Developer & Community Builder

There is a UI alignment issue on topic pages where topic heading card and the breadcrumb do not have the same margin as the rest of the cards. It's go from edge to edge on mobile/smaller screens.

What are the bugs on Tribe that you would like to report?
Daniel Paul
Full-Stack Developer & Community Builder

On mobile, after searching for anything and clicking on the dropdown result, the keyboard and the search bar are still active. The user would expect the search to dismiss once they have gotten to the page they are looking for and the keyboard dismissed to they can focus on the page they clicked on. Users are getting confused at the moment that the page has not even changed. 

Maybe I've misunderstood the UI; but, if one:

  1. Posts a poll question.
  2. Posts an answer to that poll question without voting.

that answer does not show up under the question when people click on that question (but it does show up in the feed). This leads to the somewhat paradoxical behavior that if one clicks on the answer in the feed, one is taken to a view that does not show the answer that was clicked on. 

It also triggers a few other bugs. Perhaps most severely it seems that one can re-vote an arbitrary number of times on the same question.

Because of this, it also seems impossible to edit that answer. If one tracks it down in the feed, or on the profile page, edit is not an option. I think edit is only ever shown in the view when one has clicked on the question, and since this answer is not shown there, it cannot be edited.

When I first go to my community on Android I get the popup asking if I would like to add to the home screen - I click to add, get a confirmation message - but there is no icon / link on the Home Screen (I have set all my icons). But the app has been created and I can then add it manually to the Home Screen.

I ignored the popup on another phone and instead went to the Chrome menu option to Add to Home Screen - added it successfully.

So it seems as if it is an issue with creating the Home Screen link when using the Add to Home Screen popup.

Using "edit post" and clicking "Admin tools" and then the box for "Collapse" marks a post: "This post is collapsed because of its low quality". 

However, this seems to lead to buggy behavior. If one clicks on the title of such a post, one gets to a 404 page instead of the post page. Clicking on "(More)" switches it out to "Loading", but the rest of the post never loads.

Editing subtopics of a collection-type topic and removing one subtopic seemingly removes all subtopics. When reloading the page, they other subtopics get back.

HTML code added to all sidebars inside a white box

But it appears only on the right sidebar.

Is it not supposed to appear on the left one as well?


The type drop-down when editing a topic says this about the 'Category' type: "Acts as a folder of topics. Cannot assign content to this topic type."

However, the system seems to do nothing to stop me from assigning content to a topic with this type set.

It also would be very nice if there was no "New post" box on the feed/topic pages of this topic.

Term of use and privacy policy can’t be seen on mobile

Its impossible to remove pictures and banners added to group, topic or so on. There is onle possibility to change it, but what if I dont want to have banner anymore?


You probably should add an error (or at least warning) if one in content types settings put the same thing for "Url" for more than one type, even if one of them is disabled, because that breaks things, e.g., the rss feed.

(I triggered this accidentally, as I have disabled Quick Posts and renamed Discussions to Posts.) 

2 issues related to code blocks:

  1. Automatic hyperlinking in posts should be disabled inside code blocks.
  2. In addition to inline code blocks, please provide a way to display an actual code block. Right now you wrap <code> around each new line, and it doesn't look good. Need a way to wrap it around entire code block once.

Footer links are not displayed on article, discussion, and user profile pages. We need to be able to display privacy/terms links on all pages.

{ "errors": { "general": "Invalid CSRF token" } }

When an invited Admin user is trying to register they get the error stated at the beginning.

I have not tried it with other invited members or moderators.

Member Awards

Let us give awards to members.


Let us upload the awards by ourselves and let us manually add them to the user's profile + set automatic rules like (100 discussions = award1, 100 likes = award2, 250 comments =award3, ...,)

That would encourage users to be even more active

Nat Green

I just launched my new community and there are some issues with moderating posts.

I was able to approve 2 posts but not the other 2.

Check out this video to see what I mean


Users can ask a question breaking Content Type setting

If you change who can create Questions by modifying Content Type settings, say you change it to Moderators like below. It is still possible for a regular user to create a Question. This means that the validation is not performed server side in the Create Question API.

Content Type Settings
Content Type Settings

The only way I can find for the user to access this API is through the profile completion widget in the side bar of the home feed. I have not found a setting to modify/hide this widget. But regardless of configuration options it should not prompt the user to add a question with the above setting.

Ask a question prompt
Ask a question prompt

I would expect all of the Create Post/Question etc. APIs to validate if the user has permission to do so, adhering to the Content Type settings. I would also expect that the profile completion widget does not display the Add a question option in this circumstance.

The titles of the article format are in H3. Please consider putting h1 for a better structuring of the content. On the other hand, when I put an h2, the system returns and places an h3... 

Jacek Poleszak
PL lang test @

Reputation extension resets scores and does not recalculate them!

I've tried uninstalling, reinstalling, starting fresh, it will not bring any points back or calculate again.

it resets them down to 10 and that's it.

I decided I will give more points for likes on posts, pressed recalculate... and lost everything!

I use Chrome on laptop. Some times, when refreshing, the community page goes blank and reappears when refreshing again. No other pages show such behavior.

Icon background is black, but the icon is transparent.
Icon background is black, but the icon is transparent.

The text editor cannot be translated with POEditor.

We activated "Send notifications to all group members for new posts" on a private group, but members are NOT receiving any notification via email or Telegram.

When you have an uploaded Gravatar (with your email address), as a new member the sidebar says upload a profile image.

A bit slow to open the notifications - if there are many - the less is more (and faster).

If one or more answer is deleted, on the Trending Questions show "-x answers".

What are the bugs on Tribe that you would like to report?

When you want to report a post, you cannot close the popup screen neither with close icon nor the close button.

When you add a subcategory to a category, the breadcrumbs aren't visible unlike on Tribe's community.