Skip to main content
Ask a Question
SSO (Single Sign-On)
Ross Bates
Asked a question 6 months ago

We are using Auth0 SSO. The users are created with their "email id" as their "name", and not as "username". Is there any settings that can change this behavior?

Where am I?

In Tribe you can ask and answer questions and share your experience with others!

Adrian Garcia
Digital Marketing Expert

Based on my understanding, probably you are not using "User Info URL". In this case, Tribe looks at the id_token (or the key set under JWT key in the OAuth2 app) and search for name , first_name , given_name , and username

If any of those are set, Tribe will use that. If not, Tribe uses user's ID. Most likely, in the id_token , you're passing the email address as the name when user don't have any name. 

If you login in as test123@test.com, you will most likely receiving something like this from Auth0 under id_token:


    nickname: 'test123',
    name: 'test123@test.com',
}

As you can see, Auth0 is sending test123@test.com for the name. This is something that you should change under Auth0 settings to use the name. Most likely you want to use nickname  instead of name when it's not provided rather than email address.

So, you need to modify the signup form to require full name at signup and edit a rule named "Move user metadata attributes to profile root attributes" to set "name" = "full_name". 

 

I hope it helps.